Kapitola 10. Vylepšenie fotografií

1.  Práca s digitálnymi fotografiami

1.1. Úvod

GIMP nájde svoje uplatnenie aj pri úpravách digitálnych fotografií. Existuje množstvo dôvodov, prečo treba fotografie upraviť. Fotografie môžu byť preexponované, alebo naopak podexponované. Možno ich treba trochu pootočiť, alebo doostriť. Toto sú asi najčastejšie problémy, ktoré sa dajú v GIMPe jednoducho vyriešiť. Účelom tejto kapitoly je v krátkosti popísať nástroje a situácie, v ktorých môže byť použitie jednotlivých nástrojov výhodné. Podrobné návody tu nenájdete. Vo väčšine prípadov je lepšie naučiť sa používať jednotlivé nástroje a experimentovať s nimi ako o nich iba čítať. (Každý nástroj je podrobne popísaný v príslušnej časti Pomocníka.) Nenájdete tu ani návody ako v GIMPe vytvoriť „špeciálne efekty“ a aplikovať ich na úpravy fotografií. Kým sa pustíte do tejto kapitoly, mali by ste mať s GIMPom aspoň základné zručnosti. Samozrejme, že nemusíte byť expert. Ak ním ste, pravdepodobne väčšinu z toho, čo tu bude popísané, už ovládate. Nebráňte sa experimentovaniu: GIMP má v sebe zapracovaný výkonný systém na vrátenie nepodarených krokov. To vám umožní vrátiť späť prakticky všetky chyby jednoduchým stlačením klávesov Ctrl+Z.

V podstate sa pri úpravách nie úplne perfektných fotografií zameriate na štyri problémy: vylepšenie kompozície, zlepšenie farebného efektu, doostrenia a odstránenie artefaktov.

1.2.  Vylepšenie kompozície

1.2.1.  Otočenie obrázka

Určite sa vám už veľakrát podarilo nafotiť obrázky, ktoré padajú nabok pod rôznym uhlom. Stačí, ak fotoaparát držíte nie v dokonale správnej polohe. Na opravu takejto chyby v GIMPe existuje nástroj Otočenie (Rotate). Kliknutím na ikonu rotácie v panely s nástrojmi nástroj aktivujete. Nástroj aktivujete aj pomocou klávesovej skratky Shift+R, keď je kurzor umiestnený vo vnútri obrázka. Uistite sa, že Nastavenia nástrojov sú zobrazené. Taktiež sa uistite, že navrchu nastavení nástrojov je pre položku Transform: označené tlačidlo (Transform Layer - Vrstva). Ak teraz kliknete tlačidlom myši do obrázka a potiahnete, objaví sa mriežka, ktorá sa otáča v smere ťahu. Ak ste s výsledkom spokojní, obrázok otočíte kliknutím na tlačidlo Rotate (Otočenie) alebo na kláves Enter.

Dostať obrázok do správneho uhla pomocou tejto metódy nie je jednoduché. Často zistíte, že obrázok ste síce vylepšili, ale výsledok nie je perfektný. Jedným z riešení je otočiť obrázok ešte o kúsok. Ale aj to má svoje nevýhody. Vždy, keď obrázok otočíte, stratí na ostrosti. Dôvodom je fakt, že jednotlivé pixly sa v otočenom obrázku nezaradia do línie tak ako tomu bolo v originálnom obrázku. Pri jednorázovom otočení je rozmazanie zanedbateľné. Pri druhom otočení je už miera rozmazania dvojnásobná a nie je nutné rozmazávať obrázok viac ako je potrebné. Lepším riešením je vrátiť otočenie späť, pokúsiť sa upraviť uhol otočenia a obrázok otočiť nanovo.

Našťastie v GIMPe existuje ešte jednoduchší spôsob otáčania obrázkov. V nastavení pre nástroj Otočenie, môžete pod položkou Direction označiť políčko „Backward (Corrective)“. Ak to urobíte, namiesto otáčania mriežky a kompenzovania odchýlky, obrázok otáčate s chybou, ale v línii. Ak sa vám to zdá zmätočné, vyskúšajte to, a uvidíte, že je to celkom jednoduché.

[Note] Poznámka

Od verzie GIMP 2.2 je namiesto mriežky zobrazený náhľad na vykonávané zmeny. Takto je jednoduchšie dosiahnuť želaný výsledok na prvý raz.

Po otočení obrázka sa v rohoch objavia nepríjemné trojuholníkové „diery“. Jedným z riešení je vytvorenie jednoduchého pozadia s neutrálnou farbou, čím sa rohy vyplnia. Lepšie výsledky však dosiahnete obyčajným orezaním obrázka. Čím viac obrázok otočíte, tým viac ho budete musieť orezať. Preto najlepším riešením tejto situácie je prevencia. Dobrá rada znie - snažte sa držať fotoaparát rovno.

1.2.2.  Orezanie (Cropping)

Pri fotení s digitálnym fotoaparátom existuje niekoľko nástrojov, za pomoci ktorých máte nad obrázkom značnú kontrolu. Často však nie toľko, ako by ste v danej chvíli potrebovali. Celkový dojem z fotografie umocníte aj samotným rozmiestnením všetkých dôležitých prvkov fotografie do kľúčových polôh. Dôležitým pravidlom, ktoré sa však nie vždy dá dodržať, ale je dobré naň myslieť, je pravidlo rule of thirds (pravidlo tretín). Podľa tohto pravidla maximálny efekt fotografie dosiahnete vtedy, ak dôležité prvky fotografie umiestnite do jednej tretiny obrázka, a to aj v smere na výšku aj na šírku.

Nástroj Crop (Orezanie) aktivujete stlačením príslušného symbolu v panely s nástrojmi, alebo stlačením klávesu C (veľké) s kurzorom umiestneným v obrázku. S aktívnym nástrojom orezania kliknite do obrázka a myšou ťahajte požadovaným smerom. Okolo vyznačenej oblasti sa objaví obdĺžnik. Okrem toho sa zobrazí dialógové okno. V ňom môžete presnejšie nastaviť veľkosť oblasti, ktorú chcete orezať. Stlačením tlačidla Crop (Orezať) v dialógovom okne požadovanú oblasť orežete.

1.3.  Vylepšenie farieb

1.3.1.  Automatizované nástroje

Napriek veľmi sofistikovanému systému merania expozície v dnešných digitálnych fotoaparátoch, niektoré fotografie môžu byť podexponované alebo naopak preexponované. V niektorých prípadoch je na fotografiách prítomný aj nežiadúci farebný nádych, ktorý je spôsobený nedokonalými svetelnými podmienkami. GIMP obsahuje množstvo nástrojov, ktoré vám pomôžu pri korekcií farebného podania fotografie. Na výber máte celú škálu nástrojov od jednoduchých až po vysoko sofistikované. Najjednoduchšími nástrojmi sa dá fotografia upraviť jediným tlačidlom. Pomocou zložitých nástrojov môžete pri úprave fotografii nastaviť množstvo parametrov. Začneme s tými najjednoduchšími nástrojmi.

V GIMPe nájdete niekoľko automatizovaných nástrojov na úpravu farebného podania obrázka. Žiaľ, tieto nástroje vám nie vždy poskytnú výsledok, aký by ste očakávali. Môžete ich však vyskúšať, a ak nebudete s výsledkom spokojní, aspoň získate predstavu o niektorých vlastnostiach obrázka. Všetky nástroje, okrem „Auto Levels“, môžete nájsť v hlavnej ponuke pod položkami Colors (Farby)Auto (Automaticky).

V nasledujúcom zozname nájdete stručný opis jednotlivých nástrojov:

Normalize (Normalizovať)

Týmto nástrojom (v skutočnosti je to zásuvný modul) môžete upraviť podexponované fotografie. Obrázok sa upraví po celej svojej ploche konštantne a to tak, že najsvetlejší bod obrázka bude predstavovať maximálny bod sýtosti a najtmavší bod bude čierny. Jeho nevýhodou je, že celková svetlosť obrázka je upravovaná globálne iba v rozsahu od najsvetlejších po najtmavšie body obrázka. Jediný biely pixel, alebo jeden čierny pixel nemajú na normalizáciu žiadny efekt.

Equalize (Ekvalizovať)

Toto je veľmi výkonný nástroj, ktorý sa snaží v obrázku rozložiť farby rovnomerne v celom rozsahu možných intenzít. V niektorých prípadoch dosiahnete pozoruhodné výsledky. Môžete vytvoriť dokonalý kontrast, aký by ste len veľmi ťažko dosiahli iným spôsobom. Na druhej strane však môžete vytvoriť obrázky, ktoré vyzerajú prinajmenšom čudne. V každom prípade to stojí za vyskúšanie.

Color Enhance (Vylepšenie farieb)

Týmto nástrojom zvýšite sýtosť farieb vo vrstve v celom rozsahu. Neovplyvní pritom jas ani odtieň. Táto funkcia sa nedá použiť pri obrázkoch v šedej škále.

Stretch Contrast (Roztiahnuť kontrast)

Tento nástroj sa podobá na Normalize (Normalizovať) s tým rozdielom, že pomocou neho môžete upravovať červený, zelený a modrý kanál nezávisle od seba. Takto viete upraviť nežiadúci farebný nádych fotografie.

Stretch HSV (Roztiahnuť HSV)

Nástroj pracuje podobne ako Stretch Contrast (Roztiahnutie kontrastu). Namiesto RGB (Red-Green-Blue=Červená-Zelená-Modrá) však používa farebný priestor HSV (Hue-Saturation-Value=Odtieň-Sýtosť-Hodnota). Nemení pritom odtieň.

White balance (Vyváženie bielej)

Pomocou tohto nástroja dokážete vylepšiť obrázok, v ktorom je zle podaná biela a čierna. Nástroj odstráni niektoré použité farebné odtiene a ostávajúce odtiene roztiahne po celej farebnej škále obrázka.

Auto Levels (Automatické úrovne)

K tejto funkcii sa dostanete výberom položiek hlavnej ponuky (Tools (Nástroje)Color Tools (Nástroje farieb)Levels (Úrovne) alebo Colors (Farby)Levels (Úrovne). V otvorenom dialógovom okne Levels (Úrovne) stlačte tlačidlo Auto (Automaticky). Výsledok úprav uvidíte v zobrazenom náhľade. Stlačením tlačidla Ok sa zmeny vykonáte. Stlačením tlačidla Cancel (Zrušiť) vrátite obrázok do pôvodnej podoby.

Ak v obrázku nájdete čisto bielu a dokonalú čiernu, pomocou tohto nástroja dokážete dosiahnuť výborné výsledky. Takto upravíte jas aj farby obrázka. Najprv popísaným spôsobom otvorte dialógové okno Úrovne (Levels). V spodnej časti otvoreného okna hľadajte tri symboly kvapkadiel (aspoň tak by mali vyzerať). Ak cez kvapkadlo umiestnené úplne naľavo prejdete myšou, zobrazí sa jeho funkcia Pick Black Point (Vyberte čierny bod). Kliknite na tento symbol, potom v obrázku nájdite totálne čierny pixel - musí to byť absolútne čierny bod, nie len šedý - kliknite naň a sledujte zmeny obrázka. Potom kliknite na symbol kvapkadla umiestneného úplne napravo v tejto trojici ( Pick White Point (Vyberte biely bod)) a následne kliknite do bodu v obrázku, ktorý by mal byť čisto biely. Sledujte zmeny, ktoré sa prejavia na obrázku. Ak ste s výsledkom spokojní, kliknite na tlačidlo Ok, inak použite tlačidlo Cancel (Zrušiť).

Na predchádzajúcich riadkoch sme popísali automatické úpravy farieb. Ak ani jedna z uvedených techník nespĺňa vaše požiadavky, skúste použiť niektoré z interaktívnych nástrojov. Všetky, okrem jedného, môžete nájsť v hlavnej ponuke výberom položiek Tools (Nástroje)->Color Tools (Nástroje farieb). Po výbere určitého nástroja, kliknutím do obrázka (ľubovoľne) nástroj aktivujete. Takto zobrazíte príslušné dialógové okno.

1.3.2.  Problémy s expozíciou

Najjednoduchší nástroj na úpravu jasu a kontrastu je nástroj Brightness/Contrast (Jas/Kontrast). Tento nástroj nie je obzvlášť výkonný, ale v niektorých prípadoch môže byť celkom užitočný. Je to v prípadoch, kedy sú obrázky preexponované, alebo naopak podexponované. Nehodí sa na úpravu farebného nádychu. Dvoma posuvnými jazdcami môžete upraviť Brightness (Jas) a Contrast (Kontrast). Ak máte označenú voľbu Preview (Náhľad), (a to asi máte), všetky úpravy budete môcť sledovať priamo na obrázku. Ak ste s výsledkom spokojní, kliknite na tlačidlo Ok. Úpravy sa vykonajú. Ak s výsledkom nie ste spokojní, stlačte tlačidlo Cancel (Zrušiť). Obrázok sa vráti do pôvodného stavu.

Výkonnejší nástroj na úpravu expozície a iba o trochu komplikovanejší, je nástroj Levels (Úrovne). Dialógové okno Úrovne vyzerá na prvý pohľad zložito. Pre naše potreby však bude stačiť, ak sa zameriame na časť označenú Input Levels (Vstupné úrovne). V tejto oblasti sú pod histogramom zobrazené aj tri malé trojuholníky. Viac informácií o použití tohto nástroja nájdete v nápovedi pre Levels Tool (Nástroj úrovne). Viac sa však naučíte experimentovaním. Skúšajte pohybovať jazdcami a sledujte, ako sa mení obrázok. (Uistite sa, že políčko Preview (Náhľad) je označené.)

Jedným z najvýkonnejších nástrojov na úpravu expozície sú Curves (Krivky). Tento nástroj umožňuje kliknúť do obrázka a tým preniesť príslušný bod do krivky. Následným ťahaním krivky môžete upraviť hodnoty jasu v tomto bode obrázka. Nástrojom Krivky môžete dosiahnuť obdobné výsledky, ako použitím nástrojov Jas/Kontrast alebo Úrovne. Krivky tak predstavujú oveľa výkonnejší nástroj. Detailné informácie o používaní nástroja Krivky nájdete v Pomocníkovi pre Krivky. Ako už bolo spomenuté pri iných nástrojoch, najlepšou školou je experimentovanie.

Pokročilejší používatelia GIMPu vedia, že najvýkonnejším nástrojom na úpravu jasu a kontrastu je vytvorenie novej vrstvy nad aktuálnou vrstvou a túto nastaviť do režimu Multiply (Násobenie). Režim nastavíte v dialógovom okne pre vrstvy. Nová vrstva slúži ako kontrolná vrstva pre spodnú vrstvu. Biela je nastavená na maximum a čierna na nulu. Kreslením na novú vrstvu môžete upraviť každú oblasť obrázka. Nad výsledkom tak máte dokonalú kontrolu . Ostré prechody môžu vo výslednom obrázku pôsobiť falošne. Preto by ste mali pri kreslení používať iba hladké prechody. Ak nechcete upraviť farebný nádych obrázka, na kreslenie nepoužívajte farby. Vhodné sú iba odtiene šedej.

Režim Multiply (Násobenie) nie je jediný, ktorý môže byť užitočný z hľadiska úpravy expozície. V skutočnosti sa v režime Multiply (Násobiť) dajú časti obrázku iba stmaviť, nie zosvetliť. Z tohto dôvodu sa tento režim dá použiť iba na časti preexponovaných obrázkov. Režim Divide (Delenie) má presne opačný účinok: problematické oblasti obrázka dokáže zosvetliť, ale nie stmaviť. Na tomto mieste uvádzame užitočný trik na zosvetlenie, ktorým vytiahnete detaily v celom obrázku na maximum:

  1. Skopírujte vrstvu (nad existujúcou vytvoríte novú vrstvu).

  2. Na vrstve aplikujte režim Desaturácia (Desaturate).

  3. Na vrstvu aplikujte filter Gaussovo rozostrenie (Gaussian blur) s väčším polomerom (100 a viac).

  4. Režim vrstiev v dialógovom okne nastavte na Delenie (Divide).

  5. Množstvo potrebnej korekcie kontrolujte úpravou krytia v dialógovom okne pre vrstvy, alebo použitím nástrojov Jas/Kontrast (Brightness/Contrast), Úrovne (Levels), alebo Krivky (Curves).

  6. Ak ste s výsledkom spokojní, spojte všetky vrstvy do jednej pomocou príkazu Merge Down (Splynúť dole).

Okrem režimov Multiply (Násobenie) a Divide (Delenie) môžete podobné efekty dosiahnuť aj kombináciou ďalších režimov ako sú Dodge (Zosvetliť), Burn (Stmaviť), alebo Soft Light (Mierne svetlo). Všetko je to až príliš jednoduché. Ak sa raz začnete s týmito vecami hrať a na chvíľu od počítača zdvihnete hlavu zistíte, že ste nad úpravou strávili hodinu. Je preto namieste varovať vás: čím viac možností máte, tým ťažšie sa budete rozhodovať.

1.3.3.  Úprava odtieňa a sýtosti

Ak obrázok obsahuje farebný nádych, t. j. príliš veľa červenej, príliš veľa modrej atď., podľa našich skúseností je na úpravu najlepšie použiť nástroj Úrovne (Levels). V príslušnom dialógovom okne môžete upraviť úrovne červeného, zeleného a modrého kanála osobitne. Ak tento spôsob pre vaše potreby nefunguje, môžete vyskúšať nástroje Farebné vyváženie (Color Balance) alebo Krivky (Curves). Ak však chcete tieto nástroje využívať efektívne, nebudete to mať také jednoduché. (Na niektoré špeciálne efekty sú však veľmi vhodné.)

Niekedy je ťažké povedať, kedy ste farby upravili správne. Dobrá a objektívna technika spočíva v tom, že v obrázku nájdete bod, o ktorom viete povedať, že by mohol byť biely (alebo aj v odtieni šedej). Aktivujte nástroj Farebná pipeta (Color Picker) (v Panely s nástrojmi je označená symbolom kvapkadla), a kliknite do tohto bodu. Zobrazí sa dialógové okno pre farebnú pipetu. Ak sú farby správne upravené, potom budú aj jednotlivé farebné komponenty (červená, zelená aj modrá) upravené proporcionálne správne. Ak nie sú, musíte ich podľa potreby upraviť manuálne. Táto technika môže byť spoľahlivá aj pre farboslepých ľudí. Samozrejme iba ak je použitá správne.

Ak je obrázok „vymytý“, čo sa môže stať veľmi ľahko ak fotíte v príliš svetlých podmienkach, vyskúšajte nástroj Hue/Saturation (Odtieň/Sýtosť). V otvorenom dialógovom okne máte na výber tri posuvníky: Hue (Odtieň), Lightness (Svetlosť) a Saturation (Sýtosť). Zvýšením sýtosti výzor obrázka (pravdepodobne) zlepšíte. V niektorých prípadoch je celkom užitočné v tom istom čase upraviť aj svetlosť. (Lightness (Svetlosť) sa podobá na Brightness (Jas) v nástroji Brightness/Contrast (Jas/Kontrast). Svetlosť je však tvorená inou kombináciou kanálov pre červenú, zelenú a modrú.) Nástrojom Hue/Saturation (Odtieň/Sýtosť) môžete upraviť iba obmedzený okruh farieb (použitím tlačidla nachádzajúceho sa v hornej oblasti dialógového okna). Ak však chcete dosiahnuť prirodzené podanie farieb, vo väčšine prípadov je dobré sa takémuto riešeniu vyhnúť.

Tip Tip

Zvýšenie sýtosti môže mať často pozitívny efekt aj v prípadoch, keď sa fotografia nezdá byť „vymytá“. Veteráni filmovej éry tento trik volajú Fujifying, podľa filmu Fujichrome. Ten produkoval vysoko farebne sýte fotografie.

Naopak, ak fotíte za nedostatočných svetelných podmienok, môže sa stať, že sa stretnete s presne opačným problémom: príliš sýte fotografie. V týchto prípadoch môžete na zníženie sýtosti farieb použiť nástroj Hue/Saturation (Odtieň/Sýtosť).

1.4.  Úprava ostrosti

1.4.1.  Zaostrenie

Ak pri fotení nemáte dokonale zaostrené, alebo sa počas fotenia fotoaparát pohne, výsledné fotografie sú neostré. Ak je rozostrenie príliš veľké, žiadny nástroj vám nepomôže. Ak je však rozostrenie malé, fotografiu pravdepodobne budete vedieť vylepšiť.

Najčastejšie používanou technikou na doostrenie obrázkov je nástroj Unsharp Mask (Rozostriť masku). Pomenovanie môže byť trochu zavádzajúce. Naozaj sa jedná o nástroj, ktorého účel nie je obrázok rozostriť ale naopak, doostriť. Názov techniky vznikol v minulosti, keď sa ešte používali filmy. Jedná sa o zásuvný modul a môžete ho nájsť v hlavnej ponuke pod položkami Filters (Filtre)->Enhance (Vylepšenie)->Unsharp Mask (Rozostriť masku). V otvorenom dialógovom okne nájdete dva parametre:Radius (Polomer) a Amount (Miera). Prednastavené hodnoty spravidla dávajú dobré výsledky, takže by ste mali najprv vyskúšať tieto. Zvýšením hodnoty polomera alebo miery zvýšite efekt filtra. Nenechajte sa však uniesť. Ak spravíte masku príliš silnú, vo fotografii zvýrazníte šum a viditeľné artefakty s ostrými hranami.

Tip Tip

Niekedy sa použitím filtra Rozostriť masku (Unsharp Mask) v miestach ostrých kontrastov deformuje farebné podanie obrázka. V týchto prípadoch môžete lepšie výsledky dosiahnuť rozložením obrázka do nezávislých vrstiev Hue-Saturation-Value (HSV) a aplikovať masku rozostrenia na jednotlivé vrstvy. Vrstvy môžete potom spojiť do jednej. Táto metóda pracuje celkom spoľahlivo. Využíva pritom skutočnosť, že ľudské oko je citlivejšie na jas ako na farbu. Viac informácií nájdete v častiach Dekompozícia (Decompose) a Skladanie (Compose).

V ponuke pre Filtre nájdete okrem filtra „Unsharp Mask (Rozostriť masku)“ aj filter Sharpen (Doostriť). Jeho efekt je podobný ako pri maske rozostrenia. Jedná sa o jednoduchší, ale nie tak efektívny filter. Naše odporučenie znie: Tento filter ignorujte. Radšej hneď použite filter Rozostriť masku (Unsharp Mask).

V niektorých situáciách lepšie výsledky dosiahnete selektívnym doostrením určitých oblastí obrázka. V tomto prípade použite nástroj Blur or Sharpen, ktorý nájdete v panely s nástrojmi, v režime „Sharpen (Zaostrenie)“. Maľovaním cez požadovanú oblasť obrázka ľubovoľným štetcom zvýšite ostrosť tejto oblasti. Pri používaní tohto nástroja musíte byť opatrní, lebo výsledky nebývajú príliš dôveryhodné. Doostrenie zvyšuje ostrosť hraníc medzi určitými oblasťami ale tiež do obrázka vnáša šum.

1.4.2.  Redukovanie zrnitosti (Reducing Graininess)

Ak fotíte za nedostatočných svetelných podmienok alebo fotíte s veľmi dlhým expozičným časom, fotoaparát nemá dostatok informácií k zachyteniu správnych farieb v každom pixly. Výsledkom tak býva zrnitá fotografia. Zrnitosť môžete čiastočne odstrániť vyhladením pomocou rozostrenia. Nevýhodou tohto prístupu je strata ostrosti. Existuje však niekoľko spôsobov, ktoré dávajú lepšie výsledky. Ak obrázok nie je príliš zrnitý, použite filter Selective Blur (Selektívne Gaussove rozostrenie) s nastavením hodnôt radius (polomer) 1 alebo 2 pixly. Je to pravdepodobne najlepšia voľba ako sa zbaviť zrnitosti. Ďalšou možnosťou je použiť filter Despeckle (Vyčistenie). V otvorenom dialógovom okne máte pekný náhľad. Môžete sa tak hrať s nastaveniami a úpravami dovtedy, kým nedosiahnete dobré výsledky. Ak je však zrnitosti príliš veľa, opraviť takéto fotografie je často veľmi komplikované.

1.4.3.  Rozostrenie (Softening)

Niekedy sa môžete stretnúť s opačným problémom: fotografia je príliš ostrá. Riešením býva rozostrenie. Našťastie rozostriť fotografiu je ľahšie ak ju doostriť. Keďže pravdepodobne nebudete chcieť obrázok príliš rozostriť, najjednoduchšie je použiť filter Blur (Rozostrenie). Jedná sa o zásuvný modul, ktorý nájdete v hlavnej ponuke pod položkami Filters (Filtre)->Blur (Rozostrenie)->Blur (Rozostrenie). Toto obrázok trochu zmäkčí. Ak potrebujete zjemniť ostrosť obrázka ešte viac, opakujte celý postup dovtedy, kým nedosiahnete želaný výsledok.

1.5.  Odstránenie neželaných objektov z fotografie

Existuje niekoľko typov objektov, ktoré sú vo fotografii neželané: 1. artefakty zapríčinené prachom alebo vlasmi na objektíve; 2. objekty, ktoré v skutočnosti v zábere boli ale znižujú kvalitu fotografie, napr. elektrické vedenie pred prekrásnou scenériou horského masívu.

1.5.1.  Vyčistenie (Despeckling)

Dobrým nástrojom na odstránenie prachu a iných nečistôt na objektíve je filter Despeckle (Vyčistenie). V hlavnej ponuke ho nájdete pod položkami Filters (Filtre)->Enhance (Vylepšenie)->Despeckle (Vyčistiť). Pred samotným použitím filtra je veľmi dôležité, aby ste nezabudli označiť oblasť s nečistotou plus trochu z jej okolia. Označená oblasť musí byť dosť malá na to, aby boli pixly nečistoty dokonale rozlíšiteľné od okolia v tomto výbere. Ak sa pokúsite aplikovať filter na celý obrázok, ťažko dostanete niečo použiteľné. Hneď ako vytvoríte primeraný výber, aktivujte nástroj Despeckle (Vyčistiť) a upravte jeho parametre. V náhľade sledujte zmeny. Pri troche šťastia nájdete nastavenie pri ktorom sa artefakty stratia a okolia sa to dotkne len minimálne. Čím sú artefakty lepšie oddelené od okolia, tým lepšie výsledky môžete dosiahnuť. Ak popísaný spôsob pre vás nefunguje, možno bude lepšie filter zatvoriť, vytvoriť nový výber a celý postup skúsiť znovu.

V prípade, že vo fotografii máte viac artefaktov, celý postup musíte opakovať na každý jeden zvlášť.

1.5.2.  Odstránenie balastu

Jednou z najužitočnejších metodík odstraňovania balastu z fotografie je použitie nástroja Klonovacia pečiatka (Clone) . Pomocou tohto nástroja môžete do obrázka vniesť pixly z inej časti obrázka, dokonca z iného obrázka. Celý trik efektívneho používania nástroja na klonovanie spočíva v tom, že v obrázku nájdete oblasť, ktorá sa dá nakopírovať a naniesť ju na nežiadúcu časť obrázka. Ak sa v obrázku nedá taká oblasť nájsť, asi si veľmi nepomôžete. Ako príklad použijeme fotografiu pláže po ktorej sa prechádza protivné ľudské indivíduum. To musí ísť z obrázka preč. Vo fotografii pravdepodobne budete schopní nájsť prázdnu časť pláže, ktorá vyzerá podobne ako pláž za človekom. Túto časť naklonujete a vložíte na miesto, kde sa nachádza postava. Je až udivujúce, ako prirodzene môže vyzerať výsledok, ak sa technika použije správne.

Viac informácií hľadajte v Pomocníku pre klonovaciu pečiatku. Klonovanie je niečo ako umenie a veda spolu. Čím viac ho používate, tým lepšie výsledky s ním dosiahnete. Najprv sa vám bude zdať, že výsledkom vášho snaženia sú len nepekné záplaty. Trpezlivosť však ruže prináša.

Ďalší nástroj, ktorý vyzerá podobne ako klonovacia pečiatka v menšom, je nástroj Liečenie (healing). Tiež sa ním dá preniesť časť obrázka a prekryť ňou nedokonalosť. Typickým príkladom, kde liečenie nachádza svoje uplatnenie, je odstraňovanie vrások a iných drobných nedokonalostí vo fotografii.

V niektorých prípadoch môžete dobrý výsledok dosiahnuť aj obyčajným vystrihnutím inkriminovanej oblasti obrázka a použiť zásuvný modul Resynthesizer. Tento zásuvný modul nie je základnou súčasťou GIMPu ale môžete ho získať na webovej stránke autorov [PLUGIN-RESYNTH]. Podobne ako pri použití iných nástrojov, aj v tomto prípade môže byť jeho použitie závislé od účelu. Niekedy sa hodí viac, inokedy menej.

1.5.3.  Odstránenie efektu červených očí

Ak sa osoba, ktorú fotíte s bleskom, pozerá priamo do fotoaparátu, na výslednej fotografii bude mať červené oči. Tento jav vzniká ako dôsledok odrazu svetla od sietnice oka. Na fotografiách to vyzerá naozaj podivne. Moderné fotoaparáty disponujú funkciou, ktorá spúšťa predzáblesky a tým sa pokúša tento jav minimalizovať. Nie vo všetkých prípadoch to však funguje spoľahlivo. Zaujímavosťou je, že tento jav môžeme pozorovať aj pri fotení zvierat. Farba očí na výslednej fotografii však nemusí byť len červená. Často môžeme vidieť napr. zelené oči.

Od verzie GIMP 2.4 vyššie nájdete filter odstránenia červených očí. Okolo červenej časti oka vytvorte pomocou ľubovoľného vhodného nástroja výber a použite filter Remove Red Eye (Odstrániť červené oči). Je celkom možné, že kým dostanete správnu farbu, budete sa musieť trochu pohrať s posuvníkom nastavenia.

1.6.  Uloženie výsledkov

1.6.1. Súbory (Files)

Aký formát máte použiť na uloženie výsledkov svojej práce? A mali by ste zmeniť rozmery? Odpoveď nie je jednoznačná. Záleží totiž od toho, na aké účely chcete obrázok použiť.

  • Ak chcete obrázok znovu otvoriť v GIMPe a pracovať na ňom, mali by ste ho uložiť v natívnom formáte GIMPu, t. j. XCF. (čiže meno.xcf). Len tento formát vám zaručí, že všetky informácie obsiahnuté v obrázku ostanú zachované.

  • Ak chcete obrázok tlačiť na papier, jeho rozmery by ste nemali meniť. Obrázok však môžete orezať. Dôvodom je fakt, že tlačiareň je schopná vyššieho rozlíšenia ako samotný monitor počítača. Kým pre tlačiareň je typické rozlíšenie od 600 do 1400 dpi (dots per inch = bodov na palec), pre monitory hodnoty rozlíšenia kolíšu od 72 do 100 dpi. Obrázok v rozlíšení 3000 x 5000 dpi vyzerá na monitore obrovský. Ak sa však vytlačí, jeho rozmery budú pri rozlíšení 600 dpi okolo 5 x 8 palcov (12,7 x 20,32 cm). Ani zväčšovanie obrázkov nie je dobrý nápad. Týmto spôsobom sa rozlíšenie nedá zvýšiť. Obrázok môžete zväčšiť pri tlači. Na tento účel môžete obrázok uložiť vo formáte JPEG a hodnoty kvality nastaviť v rozpätí od 75 do 85. V niektorých prípadoch, napr. ak potrebujete uložiť obrázok s veľkými oblasťami s takmer identickou jednoliatou farbou, môžete použiť aj vyššie hodnoty. Eventuálne, obrázok môžete uložiť v bezstratovom formáte TIFF.

  • Ak chcete obrázok ďalej použiť pre prezentácie na monitore alebo video projektore, nezabúdajte, že zobrazovacie systémy sú schopné dosiahnuť rozlíšenie okolo 1600 x 1200. Je teda pochopiteľné, že ukladanie obrázkov s väčším rozlíšením nie je rozumné. V pamäti zaberajú zbytočne veľa miesta. Aj pre tento účel je formát JPEG takmer vždy dobrá voľba.

  • Ak chcete obrázok vystaviť na webovej stránke alebo ho poslať emailom je dobré mať súbor s čo najmenšou veľkosťou. Prvé, čo musíte urobiť, je upraviť veľkosť obrázka na najmenšiu možnú veľkosť, pri ktorej sú ešte zachované potrebné detaily (nezabudnite, že ľudia môžu používať rôzne veľké monitory alebo ich môžu mať nastavené na rôzne rozlíšenie). Nakoniec obrázok uložte ako súbor so súborovou príponou JPEG. V otvorenom dialógovom okne označte políčko Preview in image window (Náhľad) a pomocou posuvníka nastavte akceptovateľnú hodnotu kvality. (V obrázku vidíte ako sa zmeny prejavujú.) Uistite sa, že pri tejto akcii je zväčšenie nastavené na 1:1.

Viac informácií nájdete v časti Formáty súborov.

1.6.2.  Tlač fotografií

Tak ako pri väčšine programov, aj v prípade GIMPu musíte zájsť do hlavnej ponuky a vybrať položky File (Súbor)Print (Tlačiť). Aby ste predišli nemilým prekvapeniam je dobré mať na pamäti niektoré dôležité maličkosti. Pamätajte, že:

  • na monitore je obrázok zobrazený v režime RGB, zatiaľ čo vytlačený môže byť v režime CMYK. Takže na obrázku pravdepodobne dostanete farebne niečo iné, ako vidíte na monitore a čo ste očakávali. To záleží od použitej schémy. Niektoré zaujímavé veci s vysvetlením môžete nájsť aj na Wikipedii:

  • rozlíšenie monitora sa môže pohybovať medzi hodnotami 75 a 100 dpi. Rozlíšenie tlačiarne je 10x vyššie (alebo dokonca viac) ako je rozlíšenie monitora. Veľkosť vytlačeného obrázka je závislá od množstva dostupných pixlov a rozlíšenia. Z toho vyplýva, že aktuálna veľkosť vytlačeného obrázka nemusí byť zákonite taká istá ako ju vidíte na monitore.

Pred každou tlačou obrázka je dobrým pravidlom vybrať položky hlavnej ponuky: Image (Obrázok)Print size (Veľkosť tlače). V otvorenom dialógovom okne zvoľte požadovanú veľkosť vytlačeného obrázka zmenou parametrov veľkosti tlače. Symbol znamená, že obe hodnoty sú navzájom spojené. Kliknutím na tento symbol síce môžete závislosť medzi hodnotami rozlíšenia x a y zrušiť, ale je to veľké riziko. Pravdepodobne táto možnosť je otvorená, keďže dnešným tlačiarňam je možné definovať rôzne hodnoty rozlíšenia pre x a y. Ak sa však rozhodnete toto prepojenie rozlíšenia zrušiť, s výsledkom môžete byť veľmi prekvapení. Môžete to vyskúšať. Uvidíte aké rôzne efekty dosiahnete.

Posledné odporučenie: skontrolujte si nastavenie okrajov a centrovanie. Bude škoda, ak vo vytlačenom obrázku bude chýbať časť okraja alebo ak zlým nastavením centrovania pokazíte svoju prácu, najmä ak tlačíte na špeciálny fotografický papier.

1.6.3.  EXIF Dáta

Moderné fotoaparáty pri fotografovaní zaznamenávajú aj údaje o nastaveniach fotoaparátu a ďalších okolnostiach počas fotografovania. Tieto údaje sú uložené v súboroch JPEG alebo TIFF v štrukturovanom formáte nazývanom EXIF. GIMP je schopný ukladať dáta aj pre JPEG súbory, ak je správne nainštalovaný: je totiž závislý od tzv. libexif knižnice. Tá však nemusí byť inštalovaná na každom systéme. Ak je GIMP inštalovaný s podporou EXIF dát, potom načítanie JPEG súborov s EXIF dátami, ich úprava a opätovné uloženie uchová EXIF dáta nezmenené. Popravde, toto nie je ideálne riešenie práce s EXIF dátami, ale vždy je to lepšie, ako keď editor tieto údaje jednoducho vymaže. Takto to robili aj skoršie verzie GIMPu.

Ak chcete vidieť obsah EXIF dát, môžete si stiahnuť zásuvný modul pre prehliadač EXIF dát [PLUGIN-EXIF]. Ak vám to váš systém dovolí a budete schopní ho nainštalovať, nájdete ho pod položkami hlavnej ponuky: Filters (Filtre)->Generic (Všeobecné)->Exif Browser. (Viď. Inštalácia nových zásuvných modulov.)